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OSNOVE QGIS-a ZA ARHEOLOGE 

Quantum GIS (QGIS) je besplatan, open-source geografski informacijski sustav (GIS). Kao i većina GIS programa, 
namijenjen je pohrani, obradi i analizi prostornih podataka te vizualizaciji rezultata. Podržava vektorske i rasterske 
podatke, WMS, WFS, povezivanje s prostornim bazama podataka te razne prostorne analize. Prilagođen je korisnicima s 
lako dostupnim osnovnim funkcijama za uspostavljanje vlastitih GI sustava. Kompleksniji zadaci izvode se pomoću 
Toolbox-a odnosno plugin-ova koji omogućuju pristup open-source algoritmima drugih analitičkih programa (poput 
GRASS, SAGA, R) ili aplikacijama mnogih entuzijasta open-source zajednice.  

 

1. PREGLED SUČELJA 

Program se otvara dvostrukim klikom na ikonu QGIS Desktop 2.8.9. 

Postavljanje postavki na engleski jezik: 

Menu bar > Postavke > Options > označi: Prepiši sistemske lokale > odaberi U.S. English iz padajućeg izbornika > OK > 
isključi program > uključi program 

 

Početno sučelje sadrži: 

1. Menu bar koji omogućuje pristup svim funkcijama 
i plugin-ovima, 

2. Toolbar smješten ispod menija s ikonama glavnih 
alata, 

3. Layer/Tools panel s prikazima svih slojeva (layer) 
dodanih u projekt (raspored slojeva u Panelu 
odražava se na njihov raspored u glavnom 
prozoru), 

4. Canvas (Map view) koji predstavlja glavni prozor s 
prikazom svih aktivni slojeva u trenutnom mjerilu,  

5. Status bar smješten na dnu sučelja s prikazom 
trenutnog mjerila i koordinatnog sustava (CRS) 
projekta te koordinate strelice (pointera). 

 

Alati potrebni za izvedbu radionice: 

Attribute table je tablica s atributima koje sadrži odabrani sloj, 

File properties su osobine trenutno odabranog sloja koje se otvaraju dvostrukim klikom na pojedini sloj ili desnim klikom 
i odabirom na izborniku. Kartice (tab) potrebne za radionicu su Style i Labels. 

 

Osnovni alati za navigaciju i selekciju: 

Touch zoom and pan i Pan map   

Open attribute table    

Select features i Deselect features    

Zoom to selection     

Toggle editing     

Add feature     
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2. STVARANJE QGIS PROJEKTA 

Rad u QGIS-u odvija se preko projekata odnosno datoteka s ekstenzijom .qgs. Svaki projekt može imati svoje postavke 
koje je poželjno unaprijed definirati. Postavke projekta definiraju se pomoću opcije Project > Project Properties.  

 

Definiranje koordinatnog sustava (Project > Project Properties > CRS): 

Kartica CRS  (Coodinate Reference System) omogućuje definiranje 
koordinatnog sustava pojedinog projekta. Pojedini slojevi mogu 
imati različiti CRS, a prikazivati se u projektnom CRS-u. 
Sposobnost istodobnog prikazivanja različitih koordinatnih 
sustava jedna je od velikih prednosti GIS-a kao sustava za pohranu 
i pregled prikupljenih podataka. CRS projekta i pojedinih slojeva 
može se provjeriti pod Project properties odnosno Layer 
properties. 

Projektni CRS prikazuje se u polju Selected CRS, a željeni CRS može 
se odabrati u prozoru iznad. 

Odabiremo HTRS96 / Croatia TM, EPSG: 3765 te opciju Enable 'on 
the fly' CRS transformation koja omogućuje istodobni prikaz 
slojeva različitih CRS-a u projektnom CRS-u. 

 

 

Spremanje projekta (File > Save As) 

Nakon podešavanja osobina, projekt je potrebno spremiti u definirani direktorij. Projekt se sprema u formatu .qgs kao 
jedna datoteka, dok se slojevi mogu spremati kao zasebne datoteke s različitim ekstenzijama, ovisno o njihovom formatu.  

S obzirom na način spremanja projekta i slojeva preporučljivo je odmah definirati jasnu strukturu direktorija i 
poddirektorija.  

 

3. FORMIRANJE PODLOGA 

Pod pojmom podloga obično se misli na podatke kojih nismo autori, a koristimo ih kako bi nam pomogli pri radu, 
istraživanju, obradi ili objavi podataka. Najčešće je riječ o rasterskim podlogama u obliku topografskih karata, modela 
površine (DEM), pedoloških karata te različitih prostornih podataka (granice država, županija ili općina) namijenjenih 
lakšem snalaženju ili obradi i vizualizaciji autorskih podataka. 

 

Unos WMS podataka Državne Geodetske uprave 

Standardne kartografske podloge iznimno su korisne za snalaženje u prostoru i vizualizaciju podataka. Državna geodetska 
uprava (DGU) putem protokola Web Map Service (WMS) 
omogućuje korištenje određenih državnih kartografskih podataka i 
osnovnih kartografskih slojeva u GIS okruženju (v. Podaci i Servisi: 
http://geoportal.dgu.hr/#/menu/podaci-i-servisi).  

Kartografskim podacima DGU-a moguće je pristupiti pomoću opcije 
Layer > Add layer > Add WMS/WMTS layer. U otvorenom prozoru 
odabrati New za stvaranje nove WMS veze nakon čega se otvara 
prozor Create a new WMS connection. U njemu se pripisuje ime 
novoj WMS vezi (npr. DGU DOF) te dodaje URL na WMS servis. U 
ovom slučaju to je http://geoportal.dgu.hr/services/dof/wms 
(preuzeto s gornjeg hiperlinka). Preuzimanje je potrebno potvrditi 

pomoću opcije OK. 

U prvom prozoru (Add layers…) potrebno je odabrati ime veze (npr. DGU DOF) i zatim opciju Connect nakon čega se 
prikazuju dostupni slojevi. Slijedeći korak obuhvaća odabir sloja (npr. DOF5_2011) te, nakon provjere koordinatnog 
sustava u kojem će se prikazivati ovaj sloj (HTRS96/Croatia TM), potvrdu dodavanja sloja s Add. 

Na sličan način mogu se preuzeti i ostale kartografske podloge DGU-a ili nekog drugog WMS poslužitelja. 

 

 

http://geoportal.dgu.hr/#/menu/podaci-i-servisi
http://geoportal.dgu.hr/services/dof/wms
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4. UNOS VLASTITIH PODATAKA 

Vektorski slojevi 

Vektorski podaci mogu biti zapisani u raznim formatima te je potrebno znati podržava li ih GIS koji koristimo. Vektorski 
podaci, tj. njihove koordinate mogu biti spremljene i u human-readable formatu kao tekstualna datoteka. Format Comma 
Separated Values (.csv) pogodan je tabličnu pohranu i prikazivanje podataka, ali i za korištenje u mnogim programima. 
U formatu .csv pojedina su polja, odnosno njihove vrijednosti, međusobno odvojena definiranim separatorom (zarez, 
dvotočka, točka-zarez, razmak ili tab) pomoću kojeg se vrijednosti mogu tablično prikazati. Definirani separator može se 
provjeriti u Notepadu. 

 

Unos podataka spremljenih u .csv 

Odabirom Layer > Add Layer > Add Delimited Text Layer otvara se prozor za odabir željene datoteke. Pod opcijom 
Custom delimiter potrebno je odabrati prikladan separator (npr. Semicolon). Označavanjem First record has field names 

imena polja definirana u .csv datoteci automatski se prenose u QGIS 
tablicu. Geometrijski podaci definirani su kao točke (Point 
coordinates) s poljem EASTING kao X koordinatom, a NORTHING 
kao Y koordinatom. U polju ispod odabranih opcija prikazan je izgled 
tablice, što omogućuje provjeru pravilnog prikaza podataka. 

Nakon potvrde (OK), otvara se prozor Coordinate Reference System 
Selektor koji omogućuje  definiranje koordinatnog sustava (npr. 
HTRS96 > OK) 

Unešenu .csv tablicu potrebno je spremiti kao shapefile kako bi se 
podaci mogli obrađivati. 

 

Spremanje podataka u shapefile 

Shapefile je standardni vektorski format koji je razvio Environmental Systems Research Institute (Esri). Specifikacije 
formata su javno dostupne što ga čini interoperabilnom vrstom podatka, upotrebljivom u različitim GIS programima. 
Podaci potrebni za pravilan prikaz tog vektorskog sloja spremljeni su u 4 različite datoteke: .shp (shape format, tj. 
geometrijski prikaz podataka), .shx (prostorni indeks), .dbf (datoteka s tabličnim podacima koji se prikazuju u atributnoj 
tablici) i .prj (opcionalna datoteka s podacima o projekciji). Datoteke .shp, .shx i .dbf su obavezne za pravilan prikaz 
vektorskog sloja. QGIS ima vlastiti format datoteke za zapisivanje projekcije, a to je .qpj. Ukoliko .qpj datoteka ne postoji, 
potrebno je samostalno definirati projekciju jer QGIS ne prepoznaje .prj datoteku. 
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Desnim klikom na novi .csv layer otvara se opcija Save As. 
U prozoru Save vector layer as potrebno je odabrati format 
ESRI shapefile te destinaciju za novi shapefile. Prozor 
omogućuje i provjeru koordinatnog sustava te automatsko 
dodavanje novog sloja u projekt. 

 

 

 

 

 

Unos podataka s GPS-a 

QGIS može preuzeti i prikazati podatke koji su na terenu 
zabilježeni ručnim GPS-om te omogućuje spremanje podataka u 
.gpx formatu koji je prikladan za unošenje u GPS. U prozoru 
Vector > GPS > GPS Tools pod karticom Load GPX file mogu se 
preuzeti podaci snimljeni GPS-om. Prilikom unošenja datoteke 
potrebno je odabrati vrstu GPS podataka (npr. waypoints). 
Spremanje podataka u format prikladan za unos u ručni GPS 
nudi opcija Layer > Create Layer > Create New GPX Layer. 

 

 

5. STVARANJE VEKTORSKIH PODATAKA 

Prije stvaranja sloja i iscrtavanja poligona potrebno je podesiti toleranciju snapa (Settings 
> Snapping options) koja omogućuje postizanje pravilne topologije između elemenata 
sloja (najčešće linija i poligona) i time dobivanje ispravnih rezultata pri prostornim upitima 
i analizama. U prozoru Snapping options potrebno je označiti Enable topological editing i 
Enable snapping on intersection te podesiti Tolerance na 10 px.  

 

 

 

 

U izborniku Layer potrebno je odabrati Create Layer > New Shapefile 
Layer. Otvara se prozor New Vector Layer u kojem odabiremo Type > 
Polygon te CRS: HTRS / Croatia TM. Novi shapefile može imati različita 
atributna polja koja se stvaraju osobina polja u okvir New attribute te 
dodavanjem pomoću Add to attributes list. 

 

Nakon što je novi shapefile spremljen, uređivanje sloja započinje 
odabirom opcije  

Toggle editing  i zatim Add feature   

pomoću koje se crta poligon. Postupak crtanja poligona završava 
desnim klikom čime se otvara prethodno definirana tablica za unos 
podataka o poligonu. Pri crtanju slijedećeg poligona, zahvaljujući 
podešavanju u Snapping options, crtanje je moguće započeti i završiti 
na verteksima prvog poligona čime se izbjegavaju preklapanja i 
osiguravaju pravilni topološki odnosi između pojedinih elemenata 
crteža. 
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6. OSNOVE VIZUALIZACIJE PODATAKA 

QGIS omogućuje različite načine vizualizacije vektorskih slojeva s pripisanim i kategoriziranim atributima. Desnim klikom 
na željeni sloj odabiremo opciju Properties. Otvara se prozor u kojem je moguće mijenjati osobine sloja te izmijeniti stil 
(Style) prikaza. 

U gornjem padajućem izborniku ponuđeno je nekoliko načina prikaza podataka. Odabirom opcije Graduated moguće je 
postupno klasificirati podatke u skladu s njihovim atributima. U polju Column odabire se kolona za klasifikaciju, a u polju 
Symbol oznaka za prikaz podataka. Polje Classes nudi odabir broja klasa za prikaz podataka, a polje Mode način 
klasifikacije. Color Ramp je skala koja različitim bojama prikazuje razlike u podacima, Legend format je način ispisa 
vrijednosti, dok Precision/Trim označava broj decimala, odnosno preciznost klasifikacije vrijednosti i način njihovog 
prikaza. Kada su svi parametri podešeni, klasifikacija se izvodi opcijom Classify. Uz nju su smještene još neke mogućnosti 
za naknadne izmjene koje je moguće provesti dodavanjem ili brisanjem pojedine klase. Postupak završava odabirom 

opcije Apply > OK koja je smještena pri dnu 
prozora. 

Odabrane vrijednosti mogu se izmijeniti 
vraćanjem u Properties sloja: desni klik na 
Layer> Properties. U polju s prikazom 
rezultata klasifikacije dvostrukim klikom 
na pojedini simbol moguće je izmijeniti stil 
prikaza. Na isti način mijenjaju se i drugi 
podaci: u koloni Range vrijednosti koje 
pojedini simbol prikazuje, a u koloni Label 
oznake vrijednosti svakog simbola. 
Podatak koji nije potrebno prikazati može 
se isključiti (check box), dok se preklapanje 
vrijednosti različitih simbola može 
onemogućiti isključivanjem opcije Link 
Class Boundaries. Postupak završava 
odabirom opcije Apply > OK. 

Style je moguće ponovo koristiti ako se 
pohrani kao zadani (Save as Default) ili ako 
se pohrani na računalo (Save Style as .qml) 
i zatim unosi (Load Style) po potrebi.  

 

7. OSNOVE ATRIBUTNIH I PROSTORNIH UPITA 

Atributni upiti 

Za pretraživanje i manipulaciju tabličnim podacima, tj. odabir 
elemenata putem upita, QGIS koristi Query Builder koji 
preuzima neke elemente programskog jezika SQL. 

U ovom koraku radionice, cilj je izabrati halštatsku keramiku gdje 
je nađeno 4 ili više ulomaka. 

Za oblikovanje atributnog upita pomoću opcije Query Builder 
(isključiti toggle editing - olovku ako je uključena) na kartici 
Layer Properties > General potrebno je odabrati Query builder 
pri dnu prozora.  
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A) U prvom prozoru jednim klikom odabrati 
polje za koje se postavlja pitanje, a u drugom opciju All 
koja prikazuje sve jedinstvene vrijednosti (Values) iz 
tablice. Dvostruki klik na odabrano polje ispisuje 
pitanje u donjem prozoru. Zatim se odabire Operator, 
a u polju Values dvostrukim klikom vrijednost koja nas 
zanima. Upit završava odabirom opcije OK.  

Npr. dvostruki klik na odabrano polje (keramika) > 
Operator >= values ALL > double klik na odabranu 
vrijednost (4) > OK 

B) Query je moguće proširiti ponavljanjem 
postupka: Layer Properties > General > Query builder 

i zatim npr. Operator AND > double klik na odabrano 
polje (HA) > Operator = > values ALL > double klik na 
odabranu vrijednost (DA) > OK 

C) Novi Query se pokreće ponavljanjem 
postupka: Layer Properties > General > Query builder 
> Clear 

 

 

 

 

 

Prostorni upiti 

Prikaz podataka pomoću upita (Query) čini temeljnu prednost GIS-a pa su mogućnosti postavljanja upita odnosno 
definicija polja i njihovih vrijednosti izuzetno važne prilikom oblikovanja baze podataka. Prostorni upiti (Spatial Query) 
pružaju prikaze prostornih međuodnosa slojeva, npr. 'unutar čega se što nalazi' ili 'što je blizu čega'.  

Za potrebe radionice, cilj je odabrati polja na kojima je nađena halštatska keramika (rezultat prethodnog upita). Za 
postavljenje prostornog upita potrebno je odabrati Vector > Spatial Query > Spatial Query (ukoliko ne postoji treba 
instalirati plugin). Polje Select features from označava sloj iz kojeg želimo dobiti rezultate (polja). Polje Reference 
features from označava sloj kojim je 
rezultat uvjetovan 
(GISARH_TerenskiPodaci, samo 
prethodno selektirani podaci). Polje 
Where the feature označava tip 
prostornog upita (Contains). 
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8. ISPIS (PRINT COMPOSER) 

Za ispis dobivenog prikaza potrebno je odabrati File > New Print Composer > unijeti Composer Title  

Elementi sučelja Print Composer: 

1. Menu bar koji omogućuje pristup svim funkcijama i plugin-ovima. 

2. Toolbar koji se nalazi ispod menija te sadrži ikone s alatima za upravljanje cijelim prikazom 

3. Toolbar smješten lijevo uz glavni prozor s elementima koje možemo unijeti na ispis 

4. Panele u desnom dijelu ekrana koji omogućuju upravljanje pojedinim stavkama kompozicije ispisa i prikazom svih 
izvedenih koraka. 

 

 

 

 

 

 

 

 

 

Prije sastavljanja kompozicije za ispis poželjno je odabrati View > Show Grid i zatim ponovo View > Snap to Grid što 

omogućuje preciznije postavljanje elementa kompozicije. Ta se mogućnost može dodatno unaprijediti povećanjem 

Snap Tolerance u desnom panelu: kartica Composition > Guides and Grid > Snap Tolerance. U istoj kartici uređuju se 

osobine podloge, odnosno papira: kartica Composition > Paper and Quality (npr. veličina papira, pozadina, rezolucija 

itd.). 

Za oblikovanje priloga potrebno je na lijevoj alatnoj traci (toolbar) odabrati alat Add New Map te na papiru pomoću miša 
nacrtati kvadrat unutar kojeg će se prikazati podaci iz projekta. Položaj mape može se odrediti na temelju mreže (Grid) 
ili pomoću linija vodilja (Guides) koje mišem prenosimo na prikaz, prelaskom preko ravnala (Rulers) koja okružuju glavni 
prozor. Položaj mape mijenja se odabirom alata Select/Move Item, a veličina korištenjem strelica koje se pojavljuju 
prelaskom miša preko okvira mape. Veličina se može izmijeniti i u desnom panelu pod karticom Item Properties, gdje se 
nalaze i opcije za odabir mjerila, rotaciju prikaza, izgled okvira, boju pozadine i sl. Na prikaz je ponekad potrebno dodati 
i drugačiji pogled na prostor pa je alatom Add New Map moguće dodati više mapa na isti prikaz. 

Cijeli prikaz može se približiti ili udaljiti pomoću povećala (Zoom in/Zoom out) ili, jednostavnije, pomoću kotačića na 
mišu, dok se prikaz unutar mape može mijenjati odabirom alata Move Item Content. Kada je stavka (item) postavljena 
na željeni položaj, može se zaključati pomoću lokota (Lock selected Items) na gornjoj alatnoj traci.  

Pomoću alata Add Image prikazu je moguće dodati bilo koju sliku pohranjenu na računalu (Item Properties > Main 
Properties > Image source > ... browse) ili već pripremljene simbole (Item Proprties > Main Properties > Search 
Directories). Brisanje stavke se izvodi klikom na stavku > DELETE. 

Alat Add New Label omogućuje dodavanje tekstualnih podataka. Nakon što je stavka smještena na prikladno mjesto te 
je odabrana željena veličina, u desnom se panelu, u kartici Item Properties > Main Properties, unosi tekst. Pod opcijom 
Appearance biramo font, veličinu i boju slova te položaj teksta unutra stavke. U desnom panelu moguće je izmijeniti i 
položaj, veličinu i orijentaciju stavke te izgled okvira, pozadine itd. 

Pomoću alata Add New Legend dodaje se kazalo koje automatski preuzima podatke iz projekta. Nakon podešavanja 
položaja i veličine, moguće je izmijeniti naslov (Item Properties > Main Properties > Title) i sadržaj kazala (Item Properties 
> Legend Items > uncheck Auto update > Select Items (sve što ne želimo prikazati na legendi) > crveni minus). Tekst se 
mijenja klikom na željenu stavku > olovka. U kartici Item Properties moguće je izmijeniti i druge osobine kazala: font, 
boje, broj kolona, veličine simbola, okvir, pozadinu itd. 
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Nakon što su prikazu dodani mjerilo (Add New Scalebar) i oznaka sjevera (Add Arrow), koja se pri pravilnoj orijentaciji 
prikaza crta povlačenjem miša odozdo prema gore, njihov je izgled ponovo moguće urediti u desnom panelu pod 
karticom Item Properties. Prikazu je moguće dodati i tablicu (Add Attribute Table) s podacima te ju ponovo urediti prema 
vlastitim željama.  

Print composer pruža još neke opcije: manipuliranje s više stavki istovremeno omogućuje alat Group Items smješten na 
gornjoj alatnoj traci, a stavke se razdvajaju alatom Ungroup Items. Pojedine stavke mogu se postaviti ispod ili iznad 
pomoću alata Raise, Lower, Bring to front, Send to Back, a njihovi međusobni odnosi urediti pomoću alata Align. 

Nakon što je prikaz namješten, može se ispisati (npr. Export as PDF > SAVE). 

Print composer je moguće spremiti i kao predložak (template) pa se odabrani način prikaza može ponovo koristiti 
(Composer > Save as Template > .QPT > SAVE). 

 

9. PREPORUKA 

QGIS dokumentacija za početnike: 

http://docs.qgis.org/1.8/en/docs/index.html 

Osnovni principi izrade karata: 

www.nationalgeographic.com/xpeditions/lessons/09/.../cartographyguidestudent.pdf 


